将设为首页浏览此站
开启辅助访问 天气与日历 收藏本站联系我们切换到窄版

易陆发现论坛

 找回密码
 开始注册
查看: 4262|回复: 2
收起左侧

VLAN接口动态获取IP地址配置

[复制链接]
发表于 2018-5-23 21:17:57 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?开始注册

x
VLAN接口动态获取IP地址配置* ^( f" d( a0 I% T, V3 l* o, k

8 m7 R; N  q8 P『配置环境参数』/ p- C6 G) _" q9 `# B

# B; F, k1 m- f5 F5 F8 V9 }$ n1.SwitchA为二层交换机,管理VLAN为VLAN10
, q" b, ^6 a/ e* b% Y- ^3 W6 U" d; p8 _, U' }
2.SwitchA的以太网端口E0/1为Trunk端口,连接到SwitchB,同时SwitchB提
- ]% A, R$ y1 }0 V& Q2 E" H供DHCP Server功能
+ ^8 g9 n0 l. Y  T) T
& M/ W* I1 n: ]# ?& S9 W/ }『组网需求』
, @0 {# l! u: o; i% j, O
' [) h* S0 {8 x0 O9 I) BSwitchA的VLAN接口10动态获取IP地址数据8 x% o: J( ~/ d2 ~/ ~! h. F$ G' t. @) n
# U1 c% U; I$ i) Z! c# e* j
配置步骤
$ n* n# g- o$ U6 B, n" i4 d) M( e7 ?  ]) v# W4 r
『VLAN接口动态获取IP地址配置流程』1 W' z% N$ @% F

1 B" q; Y6 s1 P3 Q在VLAN接口上配置动态获取IP地址。& {( r/ g1 l# \

: w% r+ C1 B' t7 S  L+ b【SwitchA相关配置】
; j# y( c2 n6 }% L1 v- J/ z
: [3 R1 h& T1 ?9 s: |5 G1.将E0/1端口设为trunk,并允许所有的vlan通过& ^8 c  @- Z2 t5 [8 O. z8 o
: y$ h! [% h! r- r. Q# m% C
[SwitchA-Ethernet0/1]port link-type trunk
! G4 q( M+ w' Y0 E. Y' V( I7 Q7 R8 {0 e/ v+ V: E1 x
[SwitchA-Ethernet0/1]port trunk permit vlan all
! L' w. z8 R# S; N5 B" D5 l2 n. X4 q
& X, b4 `* n6 H+ p2.创建(进入)VLAN105 e4 N: E( L* C1 K7 H* l% @

& Q6 V4 u  X: ^. O[SwitchA]vlan 10
 楼主| 发表于 2018-5-23 21:20:45 | 显示全部楼层
配置中继$ Z9 F* K- T) c
步骤 交换机1命令 交换机2命令 作用" t8 z) W9 K4 e' _! |
1 SW1#config terminal SW2#config terminal 进入特权模式1 |& R) \5 d+ O* R& p
2 SW1(config)#interface f0/24 SW2(config)#interface f0/24 进入接口配置模式
, i  g" u0 _% n! F6 O6 z3 SW1(config-if)#switchport mode trunk SW2(config-if)#switchport mode trunk 将F0/24口配置为中继' e5 t) O" _+ Q6 X% m2 C! [4 U" @
4 SW1(config-if)#end SW2(config-if)#end 返回特权模式
9 k% {9 \2 \" W2 R) R; g5 SW1#show interface f0/24 switchport SW2#show interface f0/24 switchport 查看F0/24的中继状态
/ J$ i* s2 W1 Q( E3 Y& e7 I) y四、将接口加入vlan; H& j0 H4 C0 W' I1 i! W, N5 p3 M& o
步骤 交换机1命令 交换机2命令 作用( P) }2 T' c! H
1 SW1#config terminal SW2#config terminal 进入特权模式- {6 v6 d" I+ W$ y1 B5 B
2 SW1(config)#interface range f0/1 - 10 SW2(config)#interface range f0/1 - 10 进入接口配置模式! [# k. Y; ]3 d' y
SW1(config-if-range)#switchport access vlan 2 SW1(config-if-range)#switchport access vlan 2 将f0/1-10分配给valn2* O+ H: j* W. q" i4 D- {
SW1(config-if-range)#interface range f0/11 – 20 SW1(config-if-range)#interface range f0/11 – 20 进入f0/11-20的接口配置模式
3 [% Y% _) u. D; N8 \& CSW1(config-if-range)#switchport access vlan 3 SW1(config-if-range)#switchport access vlan 3 将接口分配vlan 3
" v- B$ v# t. iSW1(config-if-range)#end SW1(config-if-range)#end 返回特权模式* q# c% Q9 R% |6 Q9 t. \2 b
SW1#show vlan brief SW1#show vlan brief 查看vlan 情况
发表于 2018-5-23 22:40:51 | 显示全部楼层
用交换机根据端口划分vlan。
, G% v7 [! H; R1 yswitch#vlan database: r2 F* {! Q* N* e) f' s
switch(vlan)#vlan 10 name v1& `9 ]" ]: n  S7 T4 H
//此步为划分出一个id是10名字是v1的vlan
0 y& A. j: M. Q$ e: H% \& c8 Lswitch(vlan)#exit$ Y3 Q. t* N' P+ a! s+ @: m; u
switch#configure terminal
+ O/ x; w# Z; ^6 `; X8 Wswitch(config)#interface f0/1: O) V- [. p! n' {
switch(config-if)#switchport access vlan 10$ Z/ u0 z- }. `1 ^  l
//此步为把f0/1划分给vlan 10,即与f0/1相连的计算机划分给vlan 10。- x% x' o5 P, ~
switch(config-if)#interface f0/2
" c# s+ k- ^: v  Qswitch(config-if)#switchport mode trunk
) J- g0 y6 D- U//f0/2为交换机间的接口。
$ C7 X9 @( E  F0 \3 ^//此步为把两台交换机间的接口配置成trunk模式,以便不同vlan能通信。  [8 b( {0 c, F
如果要实现线路冗余,可在交换机间配置快速生成树。
. f+ l( O( `$ U6 m; Q2 tswitch(config)#spanning-tree vlan 10
. S8 I# o  J7 ~switch(config)#spanning-tree mode rapid-pvst7 k- x2 G4 ]9 Y7 y: @: ~5 j
用路由器实现vlan间通信,防止外部访问本公司网络。
+ D+ W, b+ {; l8 M, Orouter(config)#interface f0/24 t9 W2 H' w1 G: K, T% X
//f0/2为路由器与交换机之间的接口。4 C7 [( j5 }. J) L/ g" h7 P
router(config-if)#no shutdown
  X6 j$ H- {5 O' J% ]$ ]router(config-if)#interface f0/0.10% {: d, E% p; i% L9 D0 Q" }
router(config-subif)#encapsulation dot1q 108 C' _& U: h' d9 {' A
//10为vlanid3 z+ B# O' W+ R1 U* i
router(config-subif)#ip address 192.168.1.1 255.255.255.0
- [- ~4 p0 k' W* ~0 _//此步为配置单臂路由,实现vlan间通信。
+ B7 e9 |: h7 urouter(config)#access-list 1 deny 10.10.1.0 0.0.0.255. i1 h+ W4 z- R/ f/ f2 N
router(config)#access-list 1 deny 10.10.2.0 0.0.0.255
# a. m7 `' D/ v+ h5 K//10.10.1.0和10.10.10.2.0为内网ip。
9 A; t/ H; [! u* ^9 S% vrouter(config)#access-list 1 permit any
" ~' Q; t" J* v# W0 J4 Srouter(config)#interface f0/04 G8 ^7 L% @% E' P7 W
router(config-if)#ip access-group 1 out
+ p6 ?2 E, N5 S( Z( @2 m* j! t! @  {//f0/0为路由器与外网接口。2 y$ `# k& J7 U- P: r
//此步配置访问控制列表,限制外网访问内网。0 B4 v2 B3 N1 S4 H. Y
以上配置全是思科的设备。
4 \7 ?7 ~. v$ M内部网络用私有ip地址即可。私有ip地址网段分别为10.0.0.0-10.255.255.255和172.16.0.0-172.31.255.255和192.168.0.0-192.168.255.255
5 c5 X& _9 N) _' O不同vlan的ip可以在同网段,也可以不同。
您需要登录后才可以回帖 登录 | 开始注册

本版积分规则

关闭

站长推荐上一条 /4 下一条

如有购买积分卡请联系497906712

QQ|返回首页|Archiver|手机版|小黑屋|易陆发现 点击这里给我发消息

GMT+8, 2021-11-28 19:07 , Processed in 0.041539 second(s), 21 queries .

Powered by LR.LINUX.cloud bbs168x X3.2 Licensed

© 2012-2022 Comsenz Inc.

快速回复 返回顶部 返回列表