将设为首页浏览此站
开启辅助访问 天气与日历 收藏本站联系我们切换到窄版

易陆发现论坛

 找回密码
 开始注册
查看: 3378|回复: 1
收起左侧

华为交换机vlan配置

[复制链接]
发表于 2018-10-28 22:24:14 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?开始注册

x
session 1 华为交换机端口模式
) e6 ^* }2 `) I- C一、华为交换机端口分为三种模式:access、trunk、hybird$ f/ }; q2 ^# W8 Q
1、access端口,用于连接主机,pvid就是该端口所属的vlan号,只能属于一个vlan. b+ T4 m: o+ x2 A
2、trunk端口,用于交换机之间连接,默认pvid是vlan1,不属于任何vlan3 Q9 M, H; _% _, L8 J- p7 s! j
3、hybird端口,是一种特殊的端口类型,默认pvid是vlan1,不属于任何vlan,是交换机端口的默认模式/ \: ]: _! {" P! x' ]* ]6 _: w& W% c, r
二、三种端口的配置命令和解释
- m+ R0 \+ E/ B8 [1、access端口vlan属性3 t, x0 R( n2 y) x
[Huawei-GigabitEthernet0/0/10]display this
5 g' s4 }5 @# @9 N7 J  V1 R#  e3 ~5 f- t. [
interface GigabitEthernet0/0/10
: i  e7 t4 T# b# f& C0 v" x port link-type access                                           配置端口的模式为access
+ C+ @/ c) Y0 u: I port default vlan 2    端口属于vlan2  t9 {0 c/ e8 E8 Y
#
& {$ k* k3 _. ]  ?5 Ireturn
/ U" M6 \3 t( B9 f" U2、trunk端口vlan属性
& l' v/ w" `; o1 y[Huawei-GigabitEthernet0/0/10]display this
7 m( G) g5 i" {) U#
3 W. n5 |: m; hinterface GigabitEthernet0/0/10+ A( b/ O/ y! h! \
port link-type trunk   配置端口的模式为trunk
9 T, P6 F* g1 F# O+ c port trunk pvid vlan 2   配置端口的pvid为vlan2
9 V5 V* s0 m4 R; S! M/ K# t port trunk allow-pass vlan 2 to 10   配置trunk允许进入的vlan-id,允许vlan1-vlan10(vlan1默认允许)
% c' ^8 F3 v% l) o#. M2 d$ K* O% D' w  ~
return
. v& Z9 _: B' A" N: F3、hybird端口vlan属性* C. l. v& [) X; P- ]  c
[Huawei-GigabitEthernet0/0/10]display this
4 ?: Z# ?0 k* Z8 G) I  q#. z7 G( a$ ]2 |) a8 D: F& g) z( _
interface GigabitEthernet0/0/10 配置端口模式为hybrid
+ ?5 B7 j+ n" d. r port hybrid pvid vlan 2 配置端口的pvid是2
& f6 Q% t$ o" x5 g" Y port hybrid tagged vlan 10 配置端口在发送帧时不将帧中的vlan10的标签去掉(类似trunk功能)$ E: T% G6 O  f! m( l% R
port hybrid untagged vlan 2 配置端口在接到帧后移除vlan2的标签后转发(给主机)3 }& R0 I% ~7 x1 G# E
#
) l" t, @& y, t: D: Nreturn
- v4 o5 m0 ~0 \3 ~8 Z4 n9 E3 j3 F# s
pvid的作用,分为端口接收和发送数据两个方向:* l' k3 Y2 S# C, t& v
1、当端口收到一个未标记的帧时,就把该帧打上vlan id,这个id值等于pvid的值,然后转发到VID和PVID相等的VLAN 中。
3 K/ L  n% z& O9 ^5 h8 g* r% d7 O2、当帧从端口向外发送出去时,如果帧头中的VID和端口的PVID值相同,就把这个标识去掉,再送出去。
% {( X( a% P# y& `% G1 n: e( w下面例子解释pvid的双向作用:
' z* H" s/ H- }. `* Y/ x" v' u
" T9 `+ Z6 ?9 ?' ~0 _       整个拓扑中PC1连接在sw1的g/0/1口,vlan1,PC2连接在sw2的g/0/1接口,vlan2
9 N" B( V8 I# `; L       SW1和SW2的g0/0/3接口都是trunk模式,其中sw1的g0/0/3接口的pvid是1,sw2的g0/0/3接口的pvid是2,并且两端trunk都允许vlan 1 to 2的帧通过。. [; m1 K; b: S, {. K/ l/ V  z
       这样配置下来的结果是pc1和pc2只要在同一个网段内就可以通信,虽然vlan不同,但是可以通信。
* ~1 x; r3 B5 J2 C1、pc1发送数据包给pc2过程是:pc1发送一个去往PC3的数据包到达sw1的e0/0/1接口,由于该接口属于vlan1所以sw1将受到的pc1的数据帧打上vlan1的标签(无标签),然后sw1查找PC3的mac,发现在接口g0/0/3下于是将数据包发给g0/0/3接口,当g0/0/3接口收到这个pc1发来的不打vlan标签的vlan1的帧后,就要将这个不打tag的帧发送出去,发现这个帧的VID和自己的PVID=1是相同的都是vlan1的于是就要把这个帧的tag去掉(vlan1默认就没有tag所以这里不做操作转发出去)然后转发出去。然后这个由PC1发来的帧被sw2在自己的g0/0/3接口收到,sw2发现收到的这个帧是没有tag的普通帧并且trunk接口的配置是允许vlan1、2通过所以会接收这个数据帧,并查看自己的pvid=2,于是就将这个数据包打上vlan2的tag,然后在vlan2的MAC表中查找PC3的mac地址发现在自己的e0/0/1接口上,于是将数据包转发到PC3。
1 Q& }* U, r/ V6 E: m) V8 w2、PC3收到PC1发来的数据包后需要给PC1回包,PC3回给PC1的包经过sw2的g0/0/1后被打上了vlan2的tag,到达g0/0/3接口,SW2发现PC3发来的这个帧有tag是vlan2,而自己的pvid=2,于是就将这个tag去掉,而接口又允许vlan1、2通过,于是就将这个去掉了tag的数据包通过g0/0/3接口转发出去,被sw1在g0/0/3接口收到,sw1查看自己的trunk配置发现接口允许vlan1、2通过就接收这个帧,然后检查该帧的VID,发现没有,于是打上vlan1的tag(也就是没有tag),然后在vlan1的MAC表中查找PC1的mac地址,发现PC1连接在自己的e0/0/1接口,就会把帧从e0/0/1接口发送给PC1,这样就完成了一次PC1与PC3的互通。7 f- N- q( N0 R
交换机SW1上的配置:
+ i2 F- n6 {, R) Z& u' s! Y[SW1-GigabitEthernet0/0/3]display this
* K, z6 s0 c3 }' }#
* p% q/ o9 l9 U4 C- I) Uinterface GigabitEthernet0/0/3
5 j! I. e* v* a2 G port link-type trunk+ T/ S; t1 t; o3 X$ s) Y' z3 [
port trunk allow-pass vlan 2                          端口pvid=1(默认)并允许vlan1、2的帧进入sw1* J2 v2 B2 r& x. a
#& N: W* M! Y" F6 S6 E$ A8 Z
return
+ V4 T: _- q  |3 g! Y[SW1-GigabitEthernet0/0/1]display this 8 @6 M$ n7 s2 |) A" _6 h
#0 `  B7 I( ~) }4 `7 M  e
interface GigabitEthernet0/0/16 a, s/ b% Z9 R- r5 u+ T
port link-type access                                     端口默认属于vlan1,连接的是pc1. \! U% S1 ?4 N& F1 t2 B
#
" p) l0 e, H4 s5 Y6 P3 Dreturn1 D. ~9 ^$ y) B/ k
交换机SW2上的配置:. c9 q6 Z9 w2 o! k, y) p# ]
[SW2-GigabitEthernet0/0/3]display this 8 N0 b  ^& k- o9 }. g
#
* D' L; j) _/ hinterface GigabitEthernet0/0/3
; w3 D' K. M( B$ W+ \/ c0 d port link-type trunk   y! g$ M, d% N5 k6 f5 b( c9 B0 v
port trunk pvid vlan 2                                   端口的pvid=2            
* p+ ^1 z3 `$ a& x) S8 ]& ~( k port trunk allow-pass vlan 2                         端口允许vlan1、2的帧进入sw2
$ D4 p  J3 {4 _" F7 B! f" O# H8 G) P#% A9 s. \8 n4 ~4 a1 }. R
return
3 R, r/ D5 K8 X[SW2-GigabitEthernet0/0/1]display this & y6 D9 x& Q# T  I
#
4 ^) O. \9 x1 B. P  e5 [* p, ointerface GigabitEthernet0/0/1
8 s7 t9 t* t# O% ^ port link-type access# x. h4 W! B, `! |6 c& l
port default vlan 2                                        端口属于vlan2,连接的是pc20 k0 d/ ]2 K- E
#
5 f- d& F' ?# Rreturn' i0 Q! G( e6 v" l: b
PC端的配置:
2 d& U( B9 \5 `: _. B8 r% qPC1:192.168.1.10/24, ]: [9 L/ @: j
PC2:192.168.1.30/24& J8 ]: U- p1 [3 o7 E5 \' U- [3 s
测试连通性( x% u. {5 O' Z! Z
PC1>ipconfig$ u1 X: Y( F, A4 P! p+ ?/ s
Link local IPv6 address...........: fe80::5689:98ff:fec3:22c4
; S% U! ?1 u7 f1 G5 Z9 }( \% [IPv6 address......................: :: / 128
2 {. G4 `  @3 H% [% P# ~4 ?IPv6 gateway......................: ::
. z+ Y+ w4 V( p/ ^% MIPv4 address......................: 192.168.1.10
8 D. Y9 X( b+ h5 k6 T2 D/ s; n( @Subnet mask.......................: 255.255.255.0
$ |) U: f1 l2 IGateway...........................: 0.0.0.0
! \; O2 y( c$ Z2 ]Physical address..................: 54-89-98-C3-22-C4
" g/ s7 \1 Y9 X3 N6 Z1 eDNS server........................:
# g1 D% v! y  C! ]3 A0 R+ nPC1>ping 192.168.1.30) L1 o/ |# b* N! A5 ?7 g8 G/ A
Ping 192.168.1.30: 32 data bytes, Press Ctrl_C to break; h: ~; r0 y2 P% l
From 192.168.1.30: bytes=32 seq=1 ttl=128 time=62 ms& Q7 J6 o; D0 \
--- 192.168.1.30 ping statistics ---$ \- }9 \% i( I
  1 packet(s) transmitted
9 w3 ~1 ~) t9 I# o; @  1 packet(s) received
* h* f2 d0 x# c! K; |  0.00% packet loss
: ?% P+ S2 h5 L. ]  o3 j  round-trip min/avg/max = 62/62/62 ms
' x! {% Z0 G& ~% j8 d+ iPC1>
, y; {1 u& K0 I
  m& K3 \  w0 h) v) j! e1 [% @# f[Huawei]clear configuration interface g0/0/1      清除接口配置,恢复默认
4 N5 N8 r5 }! k& k; ?7 y" s. p- L  r
在hybird模式中的tag和untag:
: N- ?: z4 J6 e. T( L' v       tag是指允许通过的tag的帧,功能类似trunk的allow-vlan。untag是指当接口收到帧的时候去除哪个tag,untag=2就是收到vlan2的数据帧后将tag去掉还原成普通的帧(发给主机),类似于access接口的功能。所以hybrid模式是trunk和access接口功能的集合,可以灵活使用。
: ^8 u7 m7 q1 s% P4 Q4 r4 E( f下面几个vlan划分的类型来学习hybrid端口的用法:# v" T# V+ D  Q4 D3 t
1、基于端口的vlan划分,这个就是普通的使用access模式做的,一般都用这个模式6 A. \( N. w: O9 |4 a+ M: F
2、基于ip地址的vlan划分,这个是用hybrid模式做,用于主机移动的办公环境(比如公司经常部门调整地理位置),原理是将vlan-id与ip网段进行映射绑定,只要主机的ip网段不变,那么他不管连接那个sw的那个接口都属于同一个vlan,不用担心频繁换地区导致连接sw的端口需要进行vlan的调整
; _, d: F  f) s  E3 u
/ R/ M% y1 e- m- Y. v4 b配置如下:$ {# m+ [  P2 A) w  l
首先将ip网络与vlan进行绑定,分别在sw1和sw2中创建vlan并绑定相应的ip网段(SW1与SW2配置相同,只以sw1为例)& Y& G( k( ~8 @) z9 u  @) K( p! s1 S
vlan 2
& D( c  z) q! a% q* i& y6 i/ b ip-subnet-vlan 2 ip 192.168.1.0 255.255.255.0             将192.168.1.0/24与vlan2绑定,红色的数字2是id号,不是vlan号,可以随意设置但是
! B1 l; M4 P, w5 C( N  s( T#                                                                                      一个vlan中最多可以绑定最多12个子网网段,只有12个id号
: Q  F7 A, C2 l5 m& P3 e配置sw1与sw2的级联trunk端口,并允许所有vlan通过
5 V8 f# v3 ?# S% V[SW1-GigabitEthernet0/0/3]display this   W' O3 i) R4 s. \/ {
#' S# D5 d  t" |7 z- O6 e
interface GigabitEthernet0/0/33 k+ P% a$ a& d$ z7 P4 b, J
port link-type trunk% n( Y" m$ e( k: i
port trunk allow-pass vlan 2 to 4094                          允许所有vlan通过trunk
( R- f' u+ \' J" }9 n4 I( y#9 _  S) Q4 d# z. O  B: Q' K
return
- f0 @. N" \! O/ W配置sw1连接PC的g0/0/1端口为hybrid模式,并且只允许vlan2的数据帧通过(去除vlan2的标签给pc,收到其他vlan的数据就不会去掉标签直接发给pc,而pc不能识别带有vlan标识的帧从而丢弃数据帧,达到将pc的ip绑定在vlan2中)& Y" n$ j8 [- z0 w
[SW1-GigabitEthernet0/0/1]display this
+ _' O! ~( {+ l. N, F  B+ I#
# _$ [( d& {% X* ]0 _# l. D! e9 Q# t& zinterface GigabitEthernet0/0/1: O/ U" V! w& y3 _
port hybrid untagged vlan 2                                      在发送帧(给PC)时只去掉vlan2的标签(带有其他vlan的帧不会去掉标签)2 ~2 X2 D: c/ |1 t$ B  a1 A
vlan precedence ip-subnet-vlan                                配置优先使用基于ip划分的vlan模式(默认使用基于端口的vlan模式)
: v( W+ p8 ?2 t5 P! I6 q# }% H ip-subnet-vlan enable                                                启用基于ip网络的vlan划分
( ]7 |( v$ ^9 T) b#
& v* G# O; g/ [. W  E* }return. E. y4 E9 @+ Y
       验证方法是将sw1或者sw2的g0/0/1端口port hybrid untagged vlan 2修改为其他vlan-id后pc之间就无法通信,可以抓包查看帧的vlan-id。或者将pc1与pc2的ip地址改为192.168.2.x也不通,是因为vlan2只绑定了192.168.1.0/24而没有绑定其他网段,而端口又只untag了vlan2的帧。  j* q: Z  Y: O, U  n
3、基于mac地址的vlan划分,与基于ip的vlan划分一样使用hybrid模式做,功能和基于ip地址的vlan划分类似6 x) t% ^. F. r0 B; X( L& \/ b: A
首先将pc的mac地址与vlan绑定,SW1与SW2配置相同,在vlan2中绑定pc1和pc36 M0 Z0 T9 ?7 c* I8 y( \' [4 E: D
vlan 2                              
$ u. Z2 ]1 O; R9 c( K mac-vlan mac-address 5489-98c3-22c4 priority 0& [0 m3 U- K, K- @% b4 U
mac-vlan mac-address 5489-98ce-1433 priority 0; C8 s( z/ c* b* z3 [: Q
配置sw1与sw2之间的trunk端口,允许所有vlan帧通过& z1 p, K- r8 D& N; U' \- \
interface GigabitEthernet0/0/3, a* m8 ?& H+ L# x
port link-type trunk' `+ |) [' i  o. o% P4 F) t- q! m
port trunk allow-pass vlan 2 to 4094
! r1 j3 s: U9 g, T- g! [#- r+ ~9 f4 `# B4 D( ~& d* k( `
配置sw连接pc的接口的vlan模式优先使用mac划分vlan模式(hybrid端口默认就是mac-vlan模式),开启基于mac地址的vlan划分1 M$ r0 k3 S0 _4 x, j$ ?6 N# Y2 m
interface GigabitEthernet0/0/1
" ^4 \& }& o8 b% z: ?) v port hybrid untagged vlan 2                           允许vlan2的帧通过,在发送帧(给PC)时只去掉vlan2的标签(带有其他vlan的帧不会去掉标签)
& P2 D  ?7 k1 x" n: c mac-vlan enable                                              开启基于mac地址的vlan划分. D4 W8 l# B% e1 d' W4 m' P
#
1 _' J( p5 S9 w! `9 j2 f& Q& W       验证方法与基于ip的vlan划分一样,或者可以将pc1与pc3改为其他网络,依然能通信,是因为使用的是基于mac的vlan划分,所以只要mac在一个vlan内,那么不管ip如何变化只要在一个网段内都能通信。# G' M/ N# y# E2 W( j

/ {# Q+ f5 d8 k( r8 G
 楼主| 发表于 2018-10-28 22:25:01 | 显示全部楼层
步骤:7 X/ a$ G0 h6 {+ u* x) i

0 D- J# Y. m2 O1.telnet 登录到交换机到控制台! g8 U: y. ^7 ]: Q8 O/ G3 x) ^
! J4 f$ q* t, U1 ^& d) p
2.进入系统视图,创建 2到20的vlan9 o* a) u& h% }; t% p

! s0 d& F# T, V& d: W<Quidway>sys) P/ S) W7 F2 ]! Z/ u9 o
Enter system view, return user view with Ctrl+Z.
7 d5 f% J3 y/ S/ I[Quidway]vlan batch 2 to 20
: y0 g, _8 @# @7 Y; sInfo: This operation may take a few seconds. Please wait for a moment...done.4 T* E+ b5 }6 t% Y
[Quidway]
5 v! w& Q# M( D
* C# d) \  @9 F/ n' X' r: l3.进入37口
- J7 x( H2 f4 ?) S2 m! N& S$ X3 u6 ~5 N2 S4 Y
[Quidway]int g0/0/379 C# U: r# v; |
[Quidway-GigabitEthernet0/0/37]1 P, e  B. K, ^9 c

" h, P5 k9 `- [2 _4 E  y$ z7 m: ^4.设置trunk1 W" V3 W% _) g* ?2 U3 j  d
, Z; V4 l6 N4 k9 R$ U! \) i
[Quidway-GigabitEthernet0/0/37] port link-type trunk: I3 c. k9 \* U4 t4 X

9 A& J8 ]2 m# d* B7 k6 N[Quidway-GigabitEthernet0/0/37] port trunk allow-pass vlan 2 to 4094
- w$ ^: I5 ?" L) {% H! [; W- F- N$ {( E6 v5 I# i# g
Info: This operation may take a few seconds. Please wait for a moment.....done.
3 t6 y4 x* d7 p4 ][Quidway-GigabitEthernet0/0/37], }9 P# M5 g. ]" x% h; \4 L

+ ]& N( Y6 X' \9 `2 T2 Y5.查看
# ^4 O3 g3 ^, [# ]& B/ `% [& R- Q! Q  `' X4 w$ i+ V* v
[Quidway-GigabitEthernet0/0/37]dis this" T$ N4 H! A2 ^/ G" w2 D$ ~
#8 C+ C$ q5 Q- i( K
interface GigabitEthernet0/0/37
% g6 y: I% k) T6 u port link-type trunk
6 E) B- c1 o  W. v/ t port trunk allow-pass vlan 2 to 4094! P2 |) u4 c- `% q( P9 l
#) n; q; o: ~  q" I- n
return6 X0 i2 p+ M4 w; I/ {
[Quidway-GigabitEthernet0/0/37]9 w2 T( _' H! L0 }/ l

' x) |. [% S6 t. {# m- n3 a9 C( ?6.38口设置参照以上3、4、5操作即可
2 O2 R2 M9 E4 s, |7 H- X/ v  q0 X( u! l( c+ i+ \
7.保存设置- S" k1 Z, l8 B6 k2 t
: I/ P! ]7 R9 U/ Z0 ~8 {* ]
  b" x2 |6 n3 b% c, Z6 u- q& y5 g
交换机配置好后,如果不保存,交换机断电或者重启后,配置就会丢失。
: `) @0 v4 G8 i' E. I所以,在配置好交换机后在  用户视图 执行 save  命令,就可以将配置保存到交换机上了。 注意必须是用户视图<Quidway>执行save命令。* g$ v5 c; w2 a! Z$ I' k
[Quidway]quit
1 d3 z# L1 I8 Z* |0 ^8 N$ T<Quidway> save
4 H) m  l( c( I7 Q# ?4 B$ v8 d
" {& u0 z! F/ S
您需要登录后才可以回帖 登录 | 开始注册

本版积分规则

关闭

站长推荐上一条 /4 下一条

如有购买积分卡请联系497906712

QQ|返回首页|Archiver|手机版|小黑屋|易陆发现 点击这里给我发消息

GMT+8, 2022-1-22 12:52 , Processed in 0.044503 second(s), 22 queries .

Powered by LR.LINUX.cloud bbs168x X3.2 Licensed

© 2012-2022 Comsenz Inc.

快速回复 返回顶部 返回列表